Google Play services out of date

Get via App Store Read this post in our app!

Google Play services out of date. Requires 3159100 but found 3158130

In SDK contraptions Google Play services has updated to revision 9 (version 3159100) but the Google Api’s (API 17) is still revision Trio and therefore only includes Google Play Services version 3158130

How to solve this issue??

LogCat message Google Play services out of date. Requires 3159100 but found 3158130

Thanks in Advance

Ten Answers

This is an issue with Google that arises when you update to SDK Legitimate (Jelly Bean Four.Trio) (which has now been resolved via update 21st October 2013 – see below) by Google :

It impacts Google API emulators for both Four.Two.Two and Four.Three if you are running Google Play Services.

I’m not interested in a workaround or an “unofficial” solution. This is an error caused by Google and so I’m going to wait for them to fix it. When they do, I’ll turn this response into a decent “reaction”.

This received 26th July 2013:

Comment #13 on issue 57880 by sba. @google.com: google play services updated but AVD not http://code.google.com/p/android/issues/detail?id=57880

We’re working on this. I don’t have an ETA yet other than the maddeningly vague “soon”.

This received 1st August 2013:

Updates: Status: Assigned Proprietor: sba. @google.com

Comment #Eighteen on issue 57880 by sba. @google.com: google play services updated but AVD not http://code.google.com/p/android/issues/detail?id=57880

The Play Services team knows about this issue and is working on it with a high priority. The fix for this will go in the same emulator photo in the same timeframe. Sorry I’m being vague about when it’ll go out, I don’t want to tell you something and then have us miss it. I’ll update this bug when I know more.

This is the final update on this issue (received October 21st 2013). This fix works fine for me on Four.Three – I haven’t attempted it on other flavours of Jelly Bean.

[email protected] via codesite.bounces.google.com Oct 21

to me Updates: Status: Released

Comment #45 on issue 57880 by sba. @google.com: google play services updated but AVD not http://code.google.com/p/android/issues/detail?id=57880

You may want to check at runtime whether the GooglePlayServices are up-to-date on the device or not. If not, simply display the adequate errorDialog that will prompt the user to update it.

I myself ran into this problem and found the solution here. For me it worked on target API Level 16. So I will recommend you that you create a fresh emulator with target API level 16 (Android version Four.1.Two, non-google API) and install these files on it. This will make it google-api emulator.I am posting the actual reaction for reference

” Google Play services out of date. Requires 3159100 but .. “

Here are the updated gms and vending files. Same instructions as before: Create a fresh emulator with any cpu/abi, a non google-api target (versions 10-17 work) and gpu emulation on or off, and then install the files:

If you are upgrading an existing emulator then you might need to uninstall previous versions by:

and attempt on real device , i also had the same error after updating this error was resolved or you can install the foursquare app which will redirect you to install google play services directly

GooglePlayServicesUtil.isGooglePlayServicesAvailable is deprecated. It’s recommended to use the similar method,

Just substitute jar-file in ..\libs of Google Play Services library (newest revision) with jar-file from ..\libs of Google Play Services library (older revision).

Do the same thing with jar-file in ..\bin.

It works in my case. I use Android Emulator (API Level 8) from Windows 7.

P.S. I did those things after doing necessary deeds in these tutorials:

I’ve have same problems too. The Google Maps Android V2 take me a lot of time. But fortunately, I have found some apk files and wish to share for you. Hope that useful for you.

I have test on the emulator with android api-16(Four.1.Two), api-17(Four.Two.Two), api-18(Four.Trio). It work well, and the map is shown.

1. I don’t use emulator in my case, but hope it will be any of help.

Two. It can help avoid the app from cash because of “NullPointer Error”, which is caused by mMap = mapFragment.getMap(), , but still, you need to solve how to update google play service in emulator by your self.

I got a very similar error with the latest version of google-play-services – 9.0.0. W/GooglePlayServicesUtil: Google Play services out of date. Requires 9080000 but found 9078574

The wear device refused to update Google Play Services when I went into Settings > About > Versions: Tap to View > Google Play Services (Tap on the version number)

I could fix the error by reducing the version of google-play-services used in the wearable module’s build.gradle down a version (to 8).

I’m posting in case anyone else has a similar problem with the latest version.

Related movie: 100 People Tell Us a Secret


Leave a Reply